导入开源的小程序后怎么选择合适的基础库

发布于 2020-03-28  80 次阅读


最近在给自己的博客网站做微信小程序,导入网上给的开源的小程序代码后,发布后发现6.x.x的微信版本没办法使用,提示微信版本过低,无法正常使用。

0.jfif

之前也没了解过基础库,一查才知道基础库是为了支持微信小程序组件和API等一系列的函数库。

调试出适合版本的基础库

那怎么样才知道自己的代码合适最低哪个版本的基础库呢?

其实只要在微信开发者工具 - 详情 - 本地设置 - 调试基础库

先选择1.0.1,点推送,观察模拟器有没有什么错误,有的话调高基础库,直到某个基础库调试所有界面后没问题就可以了。

20200328104907.png

20200328104941.png

设置基础库

那该如何设置基础库呢?进入小程序后台 - 设置 - 基础库最低版本设置即可。

20200328104651.png

20200328105626.png

参考:可以强制使用某一个低版本的基础库吗?

本文标题:《导入开源的小程序后怎么选择合适的基础库》

本文链接:https://wnag.com.cn/1097.html

特别声明:除特别标注,本站文章均为原创,本站文章原则上禁止转载,如确实要转载,请电联:wangyeuuu@qq.com,尊重他人劳动成果,谢过~


正因为有要好好实现的梦想,所以今天也要好好加油。