安装cailbre报错/lib64/libstdc++.so.6: version `CXXABI…

发布于 2020-03-22  144 次阅读


在an咋说能BookStack开源项目时,里面说要配置cailbre。配置后出现错误:

ImportError: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found 
(required by anaconda3/lib/python3.6/site-packages/scipy/sparse/_sparsetools.cpython-36m-x86_64-linux-gnu.so)

原因:gcc动态库版本过老

最简单的方案:

在文件中添加如下代码

将anaconda3库文件路径添加到系统的库文件路径中

 vi  ~/.bash_profile
LD_LIBRARY_PATH=/opt/anaconda3/lib:$LD_LIBRARY_PATH     
export LD_LIBRARY_PATH
$ source  ~/.bash_profile

查看版本:

strings /opt/anaconda3/lib/libstdc++.so.6 | grep 'CXXABI'

参考:python 错误解决报错信息ImportErrorlib64libstdc++.so.6: versionCXXABI_1.3.9

本文标题:《安装cailbre报错/lib64/libstdc++.so.6: version `CXXABI…》

本文链接:https://wnag.com.cn/1153.html

特别声明:除特别标注,本站文章均为原创,本站文章原则上禁止转载,如确实要转载,请电联:wangyeuuu@qq.com,尊重他人劳动成果,谢过~


正因为有要好好实现的梦想,所以今天也要好好加油。