NodeJS Puppeteer Linux(Centos)环境部署

发布于 2020-03-21  186 次阅读


安装Node环境

如果有安装Node请忽略第1点

下载

cd /usr/local/src
wget https://nodejs.org/dist/v10.15.3/node-v10.15.3-linux-x64.tar.xz

解压
tar -Jxf node-v10.15.3-linux-x64.tar.xz

将文件夹移动到 /usr/local/bin
mv node-v10.15.3-linux-x64 /usr/local/bin/node-v10.15.3-linux-x64

配置环境变量
vi /etc/profile

在"export PATH USER LOGNAME MAIL HOSTNAME HISTSIZE HISTCONTROL"上面加上

export NODE_HOME=/usr/local/bin/node-v10.15.3-linux-x64
export NODE_PATH=/usr/local/bin/node-v10.15.3-linux-x64/lib/node_modules
export PATH=$PATH:$NODE_HOME/bin:$NODE_PATH

编译/etc/profile 使配置生效
source /etc/profile

若有显示版本号证明安装成功了

node -v
npm -v

安装puppeteer

新建开发目录
mkdir pupp && cd pupp

安装cnpm,以使用淘宝镜像(用npm直接安装puppeteer会报错...)

npm install -g cnpm --registry=https://registry.npm.taobao.org

全局安装 puppeteer
cnpm install -g puppeteer

安装依赖库

yum install pango.x86_64 libXcomposite.x86_64 libXcursor.x86_64 libXdamage.x86_64 libXext.x86_64 libXi.x86_64 libXtst.x86_64 cups-libs.x86_64 libXScrnSaver.x86_64 libXrandr.x86_64 GConf2.x86_64 alsa-lib.x86_64 atk.x86_64 gtk3.x86_64 -y

安装字体

yum install ipa-gothic-fonts xorg-x11-fonts-100dpi xorg-x11-fonts-75dpi xorg-x11-utils xorg-x11-fonts-cyrillic xorg-x11-fonts-Type1 xorg-x11-fonts-misc -y

出现错误

npm ERR! Failed at the realm@2.29.1 install script

npm ERR! This is probably not a problem with npm. There is likely additional logging output above

20200330090544.png

使用 --ignore-scripts 安装 (先把某个报错的包单独安装)

npm install realm@2.1.0 --ignore-scripts

参考:nodejs puppeteer linux(centos)环境部署以及用puppeteer简单截图

npm install 报错 Failed at the XXX install script

本文标题:《NodeJS Puppeteer Linux(Centos)环境部署》

本文链接:https://wnag.com.cn/1155.html

特别声明:除特别标注,本站文章均为原创,本站文章原则上禁止转载,如确实要转载,请电联:wangyeuuu@qq.com,尊重他人劳动成果,谢过~


正因为有要好好实现的梦想,所以今天也要好好加油。